« SeaMonkey 2.4.1 Release -- Corrects Important Stability Flaw | Main | SeaMonkey 2.5 Beta 2 -- Introduces new features »

October 5, 2011

Attention: Users on older SeaMonkey Versions may be unable to update.

For those of you who are reading this and on a SeaMonkey version 2.1 through 2.3.0 you will be unable to currently update your version of SeaMonkey through automated means. (SeaMonkey 2.0.x did not have this update security measure, so is unaffected)

WHY:
Our secure certificate for updates, used to protect you, our users, from fraud and issues with the update had to be changed. The one we had expired and we were unable to renew it with the same information we baked into SeaMonkey by default.

WHAT:
We fixed this issue in our version 2.3.1, so if you have that version or newer you will not be affected. And no need to worry.

WORKAROUND:
You can manually install a new version from our website at www.seamonkey-project.org. Or apply our hotfix

HOTFIX AVAILABLE:
I have created a hotfix addon you can install into your SeaMonkey to once again update to a newer version of SeaMonkey via our internal update mechanics. This hotfix currently requires a restart of SeaMonkey, though I do plan to update it in the future to be a "restartless" addon for the versions I am able to.

NOTES:
This is different than a confusing error that gets reported in versions from 2.3.1 and newer that indicates the update server is a wrong certificate. This error is reported whenever we check against our builtin list, and of course it finds the first one we have listed as incorrect and reports it. The next cert in line is found to be ok. So this error ends up being a false positive.

Posted by Callek at October 5, 2011 3:54 PM

Comments

Post a comment




Remember Me?