« SeaMonkey 1.0 Beta Released | Main | Roadmaps - SeaMonkey 1.0, 1.1, and 1.5 »

January 30, 2006

SeaMonkey 1.0 released

It's been almost a year since the birth of the SeaMonkey project following the official end of development of the Mozilla suite, and I'm happy to announce that we made it to 1.0!

Those of you who are still using Mozilla 1.7 should try it out - same look and feel, many new features (of particular interest: drag&drop reordering of tabs, support for a common inbox for multiple email accounts, SVG, <canvas>, and phishing detection). See our official announcement for a few more details. Looking back at our 1.0 beta announcement, we did hit our target release date :-)

Posted by CTho at January 30, 2006 7:18 PM

Comments

Congrats! Well done! I think you folks have done an admirable job considering all the focus *elsewhere*. And FWIW, in SeaMonkey I get consistently good page rendering and good speed. I've only run into a few sites that look bad.

Posted by: zogger at January 30, 2006 8:46 PM

Nice, I've been waiting for this to try it out...

Posted by: David Fraser at January 31, 2006 6:38 AM

Agreed, great job!

Posted by: Mark Dowling at January 31, 2006 6:52 AM

Thanks a lot to the Council who really made a great job with managing the project. Looking ahead to the 1.1 version! :)

Posted by: prometeo at January 31, 2006 7:10 AM

Thanks a lot! All Netscape 7.x/Mozilla 1.7.x users should upgrade, it works. I hope in the future we will get more support from MoFo/MoCo, like Talkback etc.

Posted by: OstGote! at February 1, 2006 12:59 PM

Great job -- now it just needs to be optimized so it's not an order of magnitude slower than Mozilla 1.7.12, and the installer changed so the two can co-exist without clobbering each other's preferences.

Posted by: Arthur Hagen at February 1, 2006 2:15 PM

I can't build it, the make ends with:
c++ -o nsMIMEHeaderParamImpl.o -c -DMOZILLA_INTERNAL_API -DOSTYPE=\"Linux2.4\" -DOSARCH=\"Linux\" -DBUILD_ID=0000000000 -DIMPL_NS_NET -I../../../dist/include/xpcom -I../../../dist/include/string -I../../../dist/include/uconv -I../../../dist/include/mimetype -I../../../dist/include -I../../../dist/include/nspr -I../../../dist/sdk/include -I/usr/X11R6/include -fPIC -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread -pipe -DNDEBUG -DTRIMMED -O -I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/nsMIMEHeaderParamImpl.pp nsMIMEHeaderParamImpl.cpp
c++: Internal error: Segmentation fault (program cc1plus)
Please submit a full bug report.
See for instructions.
gmake[4]: *** [nsMIMEHeaderParamImpl.o] Error 1
gmake[4]: *** Deleting file `nsMIMEHeaderParamImpl.o'
gmake[4]: Leaving directory `/home/yfig/tmp/seamonkey/mozilla/netwerk/mime/src'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/home/yfig/tmp/seamonkey/mozilla/netwerk/mime'
gmake[2]: *** [libs] Error 2
gmake[2]: Leaving directory `/home/yfig/tmp/seamonkey/mozilla/netwerk'
gmake[1]: *** [tier_9] Error 2
gmake[1]: Leaving directory `/home/yfig/tmp/seamonkey/mozilla'
make: *** [default] Error 2
Does somebody knows how to do ?

Posted by: yfig at February 2, 2006 3:08 AM

I have a lot of faith in you guys.
But...
I downloaded the exe file. Ran it. Browser won't load, xbl bindings.
Twice did that.
Downloaded the zip file, ran it, hit the Seamonky exe in the folder. xbl bindings browser won;t load.
There's no forum I can find. No FAQ with issues liek that.
So I'm here.
Because of that faith.

Posted by: rollo at February 2, 2006 11:32 PM

I like it!
There are many things that are fixed since the Mozilla Suite. The only thing that annoys me is the grey box that appears when you browse the tabs.
Also an extensions manager I think would be good to be there from the start.

Posted by: Jansku at February 3, 2006 1:07 AM

Arthur, they can co-exist. They can even share a profile (though some people have seen touble sharing profiles). SeaMonkey 1.0 should actually be faster than Mozilla 1.7 based on what I've seen.

yfig, your compiler seems to be crashing. Talk to your compiler developer(?).

rollo, try a new profile. You likely have an extension installed that's breaking things.

Jansku, what gray box?

Posted by: CTho at February 3, 2006 9:34 AM

I downloaded Seamonkey and it worked great for about a day. Now it will not work at all and Mozilla will not work either. Firefox and Thunderbird are OK. In Taskmanager under Processes it shows seamonkey.exe as being loaded but, it is nor found under Applications.

Posted by: Rick at February 3, 2006 2:40 PM

SeaMonkey 1.0 is pretty nice but it crashes on Mac OS X whenever I use bookmark search.

Posted by: Paul at February 3, 2006 9:29 PM

CTho-
Thanks for the instruction. Except
a. I can't open SeaMonkey to create a new profile so, either you mean
b. a new Mozilla or Firefox profile or
c. I'm not understanding what you mean.

If it's b. I have Firefox and Mozilla and use them both daily.
And now that I think about it
d. it wouldn't do me any good to create a new profile in Mozilla or Firefox because the old ones would still be there so
e. I'm still confused.
But hopeful.

Posted by: rollo at February 4, 2006 12:32 AM

This gray box:
http://www.saunalahti.fi/~frigrenj/temp/gray_box.png

And yes, old extensions might mess things up. I uninstalled all extensions because Seamonkey wasn't working properly. Now everything works fine.

Posted by: Jansku at February 4, 2006 2:52 AM

rollo, you could try deleting (or moving away) the profile directory so it creates a new one.

jansku, that box indicates a tab has focus. Personally I find it horribly ugly in Modern - it's less offensive in other themes (e.g. Classic). You might be able to prevent it in userChrome.css with something like

tab:focus { -moz-border-top-colors: #000000 #DFE2E6 #D0D7DD !important; -moz-border-right-colors: #000000 #BAC2CD #C1C9D3 !important; -moz-border-bottom-colors: transparent !important; -moz-border-left-colors: #000000 #DFE2E6 #D0D7DD !important; }

Posted by: CTho at February 4, 2006 11:09 AM

Thanks for the help CTho. That userChrome.css hack worked. Now it looks much nicer.

Posted by: Jansku at February 5, 2006 9:41 AM

Tried to migrate from Thunderbird/Firefox, but COULDN'T. Finally got Firefox bookmarks folder moved manually, but couldn't get mail,settings,addresses migrated from Thunderbird to SeaMonkey (what a name!).
Who is SeaMonkey intended for? Don't you expect the bulk of users to migrage from Thunderbird/Firefox--at least initially until SeaMonkey reaches critical mass with users, extensions, etc?
Nice looking interface.

Posted by: Larry Livingston at February 6, 2006 9:10 AM

Larry, mail importing is currently not very friendly, but it can be done. I'd suggest asking on IRC for help. I expect most of our users will be coming from Mozilla 1.7.x, and since we actually use the same profile as Mozilla 1.7.x, no importing is needed for that switch.

Posted by: CTho at February 7, 2006 8:02 AM

Will you get a version of the calendar for seamonkey on linux?

Posted by: Joachim Geiger at February 13, 2006 7:18 AM

Calendar isn't "ready" enough yet to include in our official releases, but you can build it yourself or maybe find an XPI somewhere.

Posted by: CTho at February 14, 2006 7:18 AM

Thanks a lot to the authors.
It's really a great job for all the old Mozilla Suite users.
Please keep faith, and good luck to you all;)

Posted by: P. Wang at March 2, 2006 8:35 AM

As a longtime user of the Mozilla Suite, I'm enjoying SeaMonkey. I only have one apparent issue & don't know if this is common or unique to me.

My installation was effortless and SeaMonkey grabbed my existing Mozilla 1.7.12 web, mail and address book profiles with no obvious issues.

But the robust junk mail filtering I was getting in Mozilla is virtually non-existent. Where Mozilla mail was catching around 80% of obvious junk mail, Sea Monkey's mail program is only flagging maybe 5%, if that. And after close to a month of steady use, it doesn't seem to be "learning" anything from my manual flagging efforts either.

I didn't find this listed as a "known issue" anywhere so I'm wondering if others are having similar experiences? Or did I just miss something?

Thanks!

Posted by: T. Lassiter Jones at March 14, 2006 8:47 AM

From the HelpTurning Buttons On and Off

1. Open the SeaMonkey Edit menu and choose Preferences.
2. Click Navigator.
3. Under Select the buttons you want to see in the toolbars, choose the buttons that you want on your toolbar.
4. Click OK

There is no: "Select the buttons..." in the 1.0.1 version of Mac OS X (10.3.9)(

Posted by: Lloyd V Smith at April 20, 2006 8:07 AM