« On the state of Sunbird 1.0 beta1 | Main | [February 08, 2010] Lightning Status Update »

Lightning builds move towards supporting Thunderbird 3.1

Some people have already noticed that we no longer release nightly builds that support Thunderbird 3.0 and SeaMonkey 2.0. As of January 31st, our nightly builds will no longer live in the latest-comm-1.9.1 folder, but in the latest-comm-1.9.2 directory.

The main difference between the 1.9.1 builds and the 1.9.2 builds is, that the latter will only support nightly builds of the Thunderbird 3.1 and the SeaMonkey 2.1 development branch. This also means that our next Lightning release (1.0 beta2) will not support Thunderbird 3.0.x and SeaMonkey 2.0.x and users of those releases will have to update to be able to get the latest Lightning release then. For now, users that want to test the latest Lightning fixes should either download Lanikai 3.1 alpha1 or a recent nightly build of Thunderbird (also called Shredder) or SeaMonkey.

The reason for this decision is (again) one of (developer) resources. Currently the following development areas/branches are available to us:

  • The comm-1.9.1 branch, where development for Thunderbird 3.0 and SeaMonkey 2.0 took place.
  • The Gecko 1.9.2 branch (home of Firefox 3.6) that in combination with the (soon to be created comm-1.9.2 branch) will be the basis for Thunderbird 3.1, which is currently scheduled for a release in April 2010.
  • The so called trunk, on which the release after Thunderbird 3.1 will be developed. The SeaMonkey folks are targeting the trunk for their 2.1 release.

With our current resource situation we are not able to fully support all three areas/branches. We have therefore decided to only fully support the Gecko 1.9.2 branch and give a somewhat limited support to the trunk. Those of you who want to follow our work are encouraged to download the Lightning Nightly Updater add-on, which should make updating Lightning much easier for you.

Thanks for staying with us.

Comments

Sorry if I'm being dense, but I could use a little more guidance here.
I never switched branches, so I was still running "Shredder" which was 3.0.2pre.

I tried to download a version of Tb based on 1.9.2, which I found here: http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.2/thunderbird-3.1b1pre.en-US.mac.dmg but the latest nightly of Lightning that I found that seemed to match it ( http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-1.9.2/macosx-xpi/lightning.xpi ) reports that the version is 1.0b2pre instead of 1.1+. Is that what I should be running with to keep on the branch that you guys are actively focusing on?


google calendar provider is not functioning in the Lanikai 3.1.a1 release. It says it needs additional items.


Since the trunk builds of SeaMonkey are still highly experimental, this means I'll be going back to Sunbird for the time being, the way I "discovered" Lightning around the time when 1.0b1 was released and Sunbird builders put on hold.

That "Lightning Updater" add-on is useless for me, but for the opposite reason to that mentioned on its AMO page: every day (usually no earlier than 13:00 UTC) I connect to ftp.mozilla.org to check for nightlies of all the Mozilla applications I use (and download them if dated "today" else fall back on the latest tinderbox-build) and Lightning (before it stopped being build on comm-1.9.1) was just one of them (together with gdata-provider from the same directory. :-)

Long live the Mozilla Calendar in either of its two forms (and BTW, I suppose it would be too complicated to produce a self-standing Calendar as "Lightning for xulrunner" the way it is done with ChatZilla?)


Peter: You did install Lightning too, didn't you, and built on the same codebase (comm-1.9.2 IIUC)? Without either Lightning or Sunbird, gdata-provider cannot work.


@Daniel:
The Thunderbird 3.1b1pre builds correspond with the Lightning 1.0b2pre builds, because our next release will be Lightning 1.0 beta2, not 1.1 (we haven't released a full 1.0 yet). So you're running the right combination to keep up with our changes.

@Peter:
For the Google Calendar Provider to work, you'll need to install a corresponding Lightning build first.

@Tony:
We won't be developing Sunbird any further, so if you don't want to use the early SeaMonkey 2.1 alpha builds, you can just stay on SeaMonkey 2.0 with Lightning 1.0 beta1 and wait until there's something interesting in either apps that makes you want to upgrade.


@Simon,

I have Lanikai 3.1b1pre; Lightning 1.0b2pre; provider for google .7pre. I'm assuming that these aren't the correct combination?


@Peter:
It seems that you ran across a bug. the GData provider currently (falsely) requires a Lightning version of at least 1.1a1pre. This is wrong and should be 1.0b2pre. I filed bug 544858 to get this fixed.


@Simon,

Thanks. I'll look for the fix.


I'd like to try these builds on Ubuntu 64-bit with Thunderbird 3.1. Do these nightly builds for linux support 64-bit?


First of all I'm impressed by your work, many thanks!

But since yesterday my last solution to use lightning is gone with the new thunderbird 3.0.2 version!

I have to use the calendar with an apple iCal calendar server. This does not worked with the lightning versions for Thunderbird2 or 3. The only version that shows the events up in lightning was the combination thunderbird 3.0.1 and ligthtning 1.0b2pre.

And now the use of the bug fixes are connected to a thunderbird 3.1 version where it is not known how long it will take until it will be available. Because of the fact that I have stability problems with thunderbird 3.0.1 on Windows it's not a solution to stay a long time on this thunderbird version.

So if somebody can give me some hints how to workaround this special situation, I would be glad to use it further (One build of 1.0pre2 for Thunderbird 3.0.2 would help)?


Your choice of branches doesn't make sense

I cannot think of anything more damaging to the adoption of Lightning as a calendaring solution than your choice of branches.

As you can see here and elsewhere, people on the TB release branch are now being forced to chose between essential security updates for TB and running Lightning. Further more, any new user who downloads Thunderbird before June 2010 will receive a 3.0.x build that is incompatible with Lightning. Thus, anyone who runs an official build of TB with the most recent security patches will not be using Lightning. This is disastrous for people who have invested effort setting up these calendars, and it certainly won't help the reputation of this plugin if it is "not available" for the next three months.

Few people will want to use Lanikai in a production environment, so suggesting that people shift to Lanikai is not a real option either.

As I see it, the only sensible option is to follow the releases of Thunderbird through 3.0.x until a stable 3.1 is released. With that in mind, I strongly urge you to return efforts to working on a 3.0.x compatible version of Lightning. If you are concerned about your limited developer resources, I would also suggest delaying any support for TB 3.1 until that version of the mail client is close to release.


Regards,
Chris Boshuizen
Frustrated Thunderbird 3 user.


Chris,

we're talking about nightly builds here, not the production releases.

Frankly, anyone who is using a nightly build should know what he is getting into. If you don't want to mess with all the details of our release process and are using Thunderbird 3, then please use the Lightning 1.0 beta1 release. Users of Thunderbird 2 can still use the Lightning 0.9 release.

What I wanted to say in this blog post was, that the next release of Lightning (1.0 beta2) will only be released for the upcoming Thunderbird 3.1 release. But that is of no concern for current users, since Thunderbird 3.1 has not been released yet.


Thanks Simon.

For now, I have reverted to Lightning 1.0 beta1 releases and 0.6b of the Google provider. This allowed me to update Thunderbird to 3.0.3, which is what I wanted. It is not too bad to put up with the older Lightning version to be able to get the latest stable version of Thunderbird.

That being said, it would be really great to see a beta 1.5 of Lightning in advance of the leap to supporting Thunderbird 3.1. Is the last nightly build on that that branch not stable enough to push out? Or, is there are way we could at least update the package compatibility of the nightly build so that it can be run with Thunderbird 3.0.x?

Thanks,
Chris