another shot at pop-up blocking || MAIN || the internets are corrupted :-)

April 06, 2005

yet another 1.0.3 candidate :-)

Thanks everyone for your diligence with all the testing and feedback. We have gotten a lot of great feedback; you guys rock!

It feels like we've finally closed in on things and we're getting ready to wrap up this 1.0.3 release. I'm gonna be very cautious about calling any thing a "final" candidate, but this one feels close.

Also, we think we've got a solution that doesn't break every extension under the sun but we need your help to verify that along with any other testing help you all can give us.

You can get the builds here:

Windows
Mac
Linux

If you've got feedback, please post it here or send me email. Thanks.

Posted by asa at April 6, 2005 09:18 PM
Comments

Been playing around with it for a hour and running the JS Console like with the other 1.0.3 RC. I posted the errors on the wrong post...OOps.
http://weblogs.mozillazine.org/asa/archives/007898.html

In a nutshell. It seems to be running quite well. No crashes. Adblock is working. Downloaded a 250MB file for laughs (FlashGot). I'm using this RC for now. Don't see any reason not to.

Peace!!

Posted by: Michael Paul on April 6, 2005 09:52 PM

This build is a nice improvement over the last candidate. None of my extensions are broken now. Great work, all who worked on this.

Posted by: Rishi M on April 7, 2005 12:16 AM

The l10n-builds are suiteable, too, are they?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-aviary1.0.1-l10n/

Posted by: Morty on April 7, 2005 12:42 AM

still have the problem that flash with flashblock isnt working anymore
even deinstalling flashblock flash doesnt work anymore (reinstalled flash plugin)

get this new message in the javascript console
Error: uncaught exception: Permission denied to call method Window.eval

Posted by: andps2 on April 7, 2005 12:59 AM

Works fine for me!

Tested with
- Webdeveloper 0.9.3
- Forecastfox 0.7.1
- Flashblock 1.3.0.1
- All-in-one-gestures 0.13.4

No problems, everything worked as expected.

Only if I have Javascript Console open and close Firefox to install an extension, I get:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIObserverService.removeObserver]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://browser/content/browser.js :: Shutdown :: line 832" data: no]

Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.7.7) Gecko/20050406 Firefox/1.0.3

When I visit http://secunia.com/mozilla_products_arbitrary_memory_exposure_test/ and run the test, I get a long line of "XXXX", but no real values as with 1.0.2.

Posted by: Tobias on April 7, 2005 01:12 AM

I had problems with the browser crashing when posting and not posting correctly in the blogging system serendipity.

I was forced to go back to 1.02

Chris

Posted by: Chris Brainard on April 7, 2005 02:01 AM

Similar problem as Tobias...

Error: uncaught exception: Permission denied to call method Window.eval

Posted by: Jay MacLean on April 7, 2005 04:14 AM

I can reproduce the "uncaught exception" error on Firefox 1.0.2, looks like an older bug (or whatever).
@andps2: did you install it on a clean system or over an existing firefox installation?

Posted by: Tobias on April 7, 2005 04:35 AM

I think that zip build can't be started. At least I can't do that - I see only Firefox process, but not UI appears. I guess that the others tried .exe build

Posted by: Ivan Icin on April 7, 2005 05:32 AM

Tobias: that exception at startup has since been fixed. Bug 283116's patch was checked in on the trunk, but not the branch from which 1.0.x releases come.

Posted by: Gavin Sharp on April 7, 2005 05:42 AM

great build in all respects.....went to all the "problem" areas on websites.....no problems using this build compared to the one a few nights ago.....

peace,
chris

Posted by: Chris on April 7, 2005 06:12 AM

Looks good with webdeveloper and HTML validator

Bookmark folder with Open folder in tab, seems to close all tabs before loading new sets
But CRASH instantly on http://bcheck.scanit.be/bcheck/mangle.php talkback sent

Posted by: Mark M on April 7, 2005 06:17 AM

Bugmenot 0.6.2 gives this error message a lot of times in the js console:

Error: e has no properties
Source File: chrome://bugmenot/content/bugmenotOverlay.js
Line: 1146

...and this line once:
Error: winCount is not defined
Source File: chrome://downbar/content/downbaroverlay.js
Line: 111

Bugmenot seems to do its job however.

Posted by: SanderG on April 7, 2005 06:52 AM

Tested the Windows zip build, and Mouse Gestures 1.0 works fine.

Oh, and according to Secunia's test case, the memory-exposure bug is fixed (same output as IE: lots of X characters).

Posted by: jens.b on April 7, 2005 06:55 AM

FireFTP has problems when transfering Remote to Local...

It keeps transfering even though the file has been already tranfered... (i know because of the size) it doesn't continue with the next file, it gets stuck on the same first file...

Local to REmote, no problem...

WinXP Pro SP2, FF 1.0.3

Posted by: David Barrera on April 7, 2005 07:42 AM

The last build broke the Yahoo! toolbar extension. This build doesn't break it.
The other extensions that were broken for me are no longer broken.

I've got a lot of JavaScript console errors on startup - mostly from TabMix. I had some console errors in 1.0.2 as well, so I don't know if any of these are new to 1.0.3.

I've also been starting the installer with Firefox still running and installing over the old installation. No problems here.

In fact, no bugs to speak of for me.

Posted by: Jonnyq on April 7, 2005 07:46 AM

All 3 links are broken?

Not Found

The requested URL /pub/mozilla.org/firefox/nightly/2005-04-06-19-aviary1.0.1/ was not found on this server.

Posted by: kRush on April 7, 2005 07:58 AM

It seems that 1.0.3 candidate doesn't work with my profile :(.

I'll report on extensions later

Posted by: Ivan Icin on April 7, 2005 08:00 AM

Yeah sure, just as I finished posting it they work again.

Posted by: kRush on April 7, 2005 08:02 AM

I'm getting an error with extensions that try to open a sidebar (ie. Calculator, Quicknote). I haven't noticed any actual functionality problems, but the JavaScript Console reads:
Error: searchBox has no properties
Source File: chrome://browser/content/browser.js
Line: 3337

using windows xp, feel free to email me if you need more info.

Posted by: Joey on April 7, 2005 08:09 AM

I have been using Firefox for a long time now and when 1.02 came out I almost wanted to switch back to Internet Explorer. My firefox would shut off every 20 minutes it was horrible. Now with this 1.03 Beta I haven't had one lock up yet. Thanks for a great browser.

Posted by: Malfa on April 7, 2005 08:21 AM

I uninstalled 1.0.2 final and installed the 1.0.3 RC. I then installed the latest stable build of NewsMonster (1.2.2). After closing my browser, firefox will not restart. Spikes CPU to 99% until the process is killed.

Posted by: coppertrail on April 7, 2005 08:24 AM

Does it still work with this Shockwave 3D game?

http://www.esuvee.com

Then click on the Play Esuvee Course button

Posted by: bloFisher on April 7, 2005 08:45 AM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050406 Firefox/1.0.3

after installed 1.0.3 some extension didn't work. and i have to uninstall and reinstall the extiontions: Stop/Reload 1.1, Duplicate Tab 0.5.1, Tab Clicking Options 0.5.1 , Customizable Toolbar Buttons 0.1.5 , FastDic 0.2.4.

now all my 44 extensions working good

Posted by: h.h on April 7, 2005 08:48 AM

Installed over 1.0.2. All went smooth here. No break of any of my extensions: Tabbrowser Preferences, Tiny URL creator, AdBlock,SpellBound, IEveiw,cookieCuller.
Java script runs fine here with no freezing and scurity bug taken care of..
XP SP2

Posted by: xrayspex on April 7, 2005 09:43 AM

Mark M said "CRASH instantly on http://bcheck.scanit.be/bcheck/mangle.php"

Crash confirmed here.

Posted by: Phil Randal on April 7, 2005 10:31 AM

Installed over 1.0.2 fine, no problems.

All following extensions seem OK:

FlashBlock 1.3.0.1
Download Tweak 0.6.5
BBCode 0.3.7
AdBlock v5 d2
Mozilla Calendar 0.8.1+
downThemAll 0.9.4
WebDeveloper 0.9.3
TabBrowser Preferences 1.2.2
TinyUrl Creator 0.7.1
Disable Targets for Downloads 0.9
UserAgent Switcher 0.6.1

Posted by: -A- on April 7, 2005 11:06 AM

Current 1.0.3 candidate seems to have problems running Java. E.g., with 1.0.2 installed, the Java test at: http://java.com/en/download/help/testvm.xml
runs just fine. Installing 1.0.3 causes the test to fail.

Posted by: michael edson on April 7, 2005 11:19 AM

To michael edson:

I am using WinXP SP1 and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050406 Firefox/1.0.3 and the Java test page worked for me.

Posted by: Dave on April 7, 2005 11:25 AM

Ok, I just installed this latest build and so far so good. I'm still getting the JavaScript errors I reported last time:

Error: getBrowser().contentDocument has no properties
Source File: chrome://ahb/content/ahb_overlay.js
Line: 41

Error: document.getElementById("ahb-button") has no properties
Source File: chrome://ahb/content/ahb_overlay.js
Line: 240

Error: document.getElementById("popupMenuExchange") has no properties
Source File: chrome://translation/content/popup.js
Line: 50

Error: document.getElementById("ahb-button") has no properties
Source File: chrome://ahb/content/ahb_overlay.js
Line: 240
(*** This one repeats a lot ***)

I'm running Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050406 Firefox/1.0.3

I'm not sure if those above errors are anything to be concerned with but they don't seem to impact my Firefox usage at all.

Peace...

Posted by: Tom on April 7, 2005 11:45 AM

I'm using Mac Os X 10.3.8, and this new 1.0.3 candidate work fine.

Jean

Posted by: jean on April 7, 2005 11:57 AM

Don't know if this is specific for this 1.0.3 candidate (I doubt it is) but when I tried to write a reply over at the IE blog the find-bar kept popping up for every keystroke... EXTREMELY annoying ;-) Now, for all I know, this could be due to the IE blog using some strange code...

Posted by: David Naylor on April 7, 2005 12:12 PM

Installed over 1.0.3 RC (second set)

All following extensions seem OK:

AdBlock v5 d2
Focus Last Selected Tab 0.8.2
Download Tweak 0.6.5
WebDeveloper 0.9.3
TabBrowser Preferences 1.2.2
Add Bookmark Here 0.5.3
ColorZilla 0.8.2
CuteMenus 0.4
Local Install 1.2.5
Paste and Go 0.4.1
Translation Panel 1.4.13

Windows XP Pro SP2, no problems using this build compared to RC (second set). No javascript errors.

Posted by: Darken on April 7, 2005 12:19 PM

Java applets wont open in speed test sites such as www.broadbandreports.com and http://www.speakeasy.net/speedtest/.
On 1.0.2 they open fine here.
Having trouble veiwing java applets on other sites as well that use them on 1.0.3

Posted by: xrayspex on April 7, 2005 12:48 PM

Can't right-click on flash applets and choose "About Macromedia Flash" anymore.

Is it possible to selectively re-enable popups for cases such as this?

Maybe ship a pre-populated whitelist with Firefox?

Posted by: Kevin on April 7, 2005 12:51 PM

ImageZoom 0.1.7 break links and cause firefox to hang on exit. Application closes but firefox process still running, unable to restart firefox

Posted by: Mark M on April 7, 2005 01:06 PM

@xrayspex

Just loaded the speedtest site at the URL you quoted fine using Java 1.5.0

WinXP SP2

Posted by: -A- on April 7, 2005 01:07 PM

@Kevin

Right-Clicking a flash applet and choosing "About Macromedia Flash" works fine here - Using FlashPlayer v7

Posted by: -A- on April 7, 2005 01:10 PM

Imagezoom 0.1.7 breaks on http://www.theregister.co.uk/2005/04/07/linux_windows_quocirca/ top link

Posted by: Mark M on April 7, 2005 01:17 PM

Had problems with viewing flash & apple trailers (not loading @ all).
The problem was "adblock" (version 0.5.2.039)

After disabling this extension it worked again

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050406 Firefox/1.0.3

No other problems over here :)

Posted by: Da Dude on April 7, 2005 01:20 PM

@ Da Dude : Apple trailers works fine with AdBlock :)

Posted by: Darken on April 7, 2005 01:42 PM

A- I am using java 1.5.2 which is the latest build.

Posted by: xrayspex on April 7, 2005 02:06 PM

Does the solution you mention address bug 281988 so extensions should not need to use XPCNativeWrapper? If not, is it the solution that was applied / patched a few days ago to address the secunia advisory or is it a new solution?

Thanks,
Robert

Posted by: Robert Strong on April 7, 2005 02:31 PM

@ Darken: here it doesn't, but please note, i'm using an unofficial build of quicktime called alternative quicktime (which normally works good)

Posted by: Da Dude on April 7, 2005 04:08 PM

@ Da Dude : Oh... arfff, sorry, i'm using official Quicktime plugin... ;)

Posted by: Darken on April 7, 2005 06:03 PM

As other people have said, Adblock doesn't allow Java to work. With Adblock disabled, the applet at http://acg.media.mit.edu/people/fry/zipdecode/ is fine, but with Adblock enabled, it only shows the thing that says 250 miles at the top-right and the zoom button at the bottom-right.

JavaScript console showed this:

Error: document.applets[0].focus is not a function

That's with Java 1.4.2_07-b05 (according to about:plugins) on Linux.

Also, this error appears in the JS console when Firefox starts up:

Error: this.mTabBrowser.mProgressListeners has no properties
Source File: chrome://global/content/bindings/tabbrowser.xml
Line: 343

It may be because of one of my six thousand extensions, but I doubt it.

http://home.ripway.com/2004-3/80433/stuff2/infolister-firefox2.html

Posted by: Peng on April 7, 2005 09:48 PM

All right, went to AnandTech's homepage, and the Flash banner ads displayed fine. about:plugins says it's version 7.0 r25.

Posted by: Peng on April 7, 2005 09:52 PM

Hmm, the JavaScript console error about the Java applet may have been because I clicked on it.

Also, I may just be imagining this, but it feels like Firefox starts up faster than with the third 1.0.3 release candidate (this is the fifth, right?).

Posted by: Peng on April 7, 2005 10:05 PM

Flash animations/games wouldn't play after installation. Creating a new profile cured that. When some extensions were installed into the new profile, Flash stopped working again. Since I installed the extensions all in one go, I'm not sure which one is causing the problem. It'll need some experimenting to find out.

Installed extensions are:

Adblock 'Buttons edition' 0.5.2+
BBCode 0.3.7
BugMeNot 0.6.2
Clone Window 0.2.5
Compact Menu 1.7.1.2
CuteMenus 0.4
ieview 0.86
PopupALT Attribute 1.3.2005040101
QuickTabPrefToggle 0.0.4
SpoofStick 1.05
BGM Conductor 2.0.3

Posted by: mart44 on April 7, 2005 11:27 PM

Apologies. I hadn't noticed Da Dude's comment about Adblock. Disabling this does make Flash work again.

Posted by: mart44 on April 7, 2005 11:35 PM

I'm having trouble printing. Doesn't print as displayed (one frame(?) over the other).

using: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.7) Gecko/20050406 Firefox/1.0.3

Posted by: FB88 on April 7, 2005 11:45 PM

A mailto link does not work anymore here:
http://www.marktplaats.nl/email.php3?g=hardware&u=geheugens&ID=71653&ret=%2Fmarkt%2Fhardware%2Fgeheugens%2F71653.htm%3Fret%3D%252Fnieuw_zoek.php3%253Fq%253Dpc3200

(click the upper Verstuur button)

Posted by: SanderG on April 7, 2005 11:46 PM

I thought I would check out HushMail to see how that was going. Just couldn't get it to work. In fact Hushmail is one page that I've never really been able to get to work in Firefox.

Java Console error...

Error: hushAppletFrame.navigation.getApplet().resetLastError is not a function
Source File: https://mailserver2.hushmail.com/hushmail/showLogin.php?PHPSESSID=**********3417612730fa5562771a9
Line: 142

Posted by: Michael Paul on April 8, 2005 12:07 AM

Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.7) Gecko/20050407 Firefox/1.0.3

FireFTP 0.87
FLST 0.8.1
Paste and Go 0.4.1
Sage 1.3.1
Super DragAndGo 0.2.4
Tab Clicking Options 0.5
Tabbrowser Preferences 1.2.2
Tweak Network 1.0
Paste Quote 0.3
BBCode 0.3.7
Web Developer 0.8
Bookmarks LinkChecker 0.6.8
ForecastFox

All these extensions work fine :)

Good job.

Posted by: Youp3 on April 8, 2005 12:30 AM

hello,
dadude is right, the problem is adblock
with it disabled flash works again and so does flashblock

greetings

Posted by: andPS2 on April 8, 2005 01:13 AM

Don't suppose the 'accessibility.typeaheadfind.enabletimeout setting ignored' bug could get fixed in 1.0.3 (pretty please? :) Its been a pet peeve of mine ever since I encountered it in 1.0

Posted by: Limulus on April 8, 2005 02:56 AM

having installed the latest build (good work btw with the prompt security update) not really noticed any issues except i can no longer right click in the browser, as soon as i do firefox crashes and wants to create a dump file.

Other than that the build works perfectly for me ( however i dont use too many extensions)

keep up the good work people, firefox rules !

Posted by: Anthony on April 8, 2005 03:41 AM

FYI, flash works with adblock enabled if obj-tabs is disabled.

Posted by: rick on April 8, 2005 11:29 AM

rick: What exactly to Obj-Tags do, anyway?

Posted by: Peng on April 8, 2005 01:43 PM

Peng: as per http://www.webhostingtalk.com/archive/thread/330785-1.html

The "Obj-Tabs" option puts an "Adblock" tab above embedded objects such as flash movies and embedded real media content. I find these tabs annoying so I prefer to have this option unchecked. The point of these tabs is just an easy way to add the embedded content to your filter list. Since the existing filters used in combination with the below methods will block pretty much all embedded ads such as flash anyway I find I never use this feature and I'd rather have legitimate flash movies not have the ugly tab visible.

Posted by: Limulus on April 8, 2005 04:46 PM

Can anybody else check if quicktime files works in FF with alternative quicktime (its the same as quicktime, only it gets rid of the commercials and it doesn't stay in your programmbar etc..)

also here's my installed extension list

Adblock 0.5.2.039
Add Bookmark Here 0.5.3
Add N Edit Cookies 0.2.0.4
Allow Right-Click 0.1.1
AutoLogin 0.2
Browse Images 0.2
Chrome Cleaner 0.3
Context Search 0.2
Copy Image 0.3
Copy To Clipboard 0.1
DictionarySearch 0.8
Disable Targets For Downloads 0.9
Download Manager Tweak 0.6.5
Duplicate Tab 0.5.1
ieview 0.86
Image Zoom 0.1.7
Linkification 0.9.20
ListZilla 0.5.1
Minimize to Tray 0.0.1.20050212
MR Tech Local Install 1.2.5
OpenBook 1.2.0
Popup ALT Attribute 1.3.2005040101
Popups Must Die! 1.1
RiteOfTongue 0.3
Slim Extension List 0.1
Tabbrowser Preferences 1.2.3
Translation Panel 1.4.13.0.1
User Agent Switcher 0.6.4
ViewSourceWith 0.0.6
Web Developer 0.9.3

Posted by: Da Dude on April 8, 2005 07:13 PM

Limulus: Ack, should have looked around a bit. :P Anyway, thanks for the explanation. Hmm, I use those a lot. I like not to block many ads, but if there's a blinky flashy active Flash ad that's bugging me, obj-tags make it a lot easier to block. Well, Flash works fine -- it's only Java I'm having trouble with, and I hardly ever use it, so I guess I'll keep obj-tags enabled.

Posted by: Peng on April 8, 2005 07:57 PM

Just to say, in the 20050408 version, I'm having no problems with the zipdecode Java applet with Adblock enabled. :)

I do still get that error in the JavaScript console when I view a page with a Java applet, though, and I also get this:

Error: this.mTabBrowser.mProgressListeners has no properties
Source File: chrome://global/content/bindings/tabbrowser.xml
Line: 343

But, this probably isn't the right place to be saying all this. >.>

Posted by: Peng on April 8, 2005 10:10 PM

The DownThemAll Extension seems to have been b0rked by the latest candidate.
No filtering is possible anymore.

Posted by: Bastian Grupe on April 8, 2005 11:31 PM

Nevermind, has been fixed in latest latest 1.0.3 candidate.

Posted by: Bastian Grupe on April 8, 2005 11:38 PM

Quote Da Dude: Can anybody else check if quicktime files works in FF with alternative quicktime (its the same as quicktime, only it gets rid of the commercials and it doesn't stay in your programmbar etc..)...

Never heard of an "alternative" QT, but works just fine with my current registered QT 6.5.2 and latest FF build just posted few minutes ago (e.g., Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.7) Gecko/20050408 Firefox/1.0.3).

Posted by: Skylark on April 9, 2005 02:30 AM

Skylark you should give it a try :) (going a little offtopic here)
http://www.free-codecs.com/download/QuickTime_Alternative.htm

It so much better then the official one

Posted by: Da Dude on April 9, 2005 06:25 AM

Post a comment